同样 ,谷歌规范因为存在多个匹配规则时,何解常见格式为 <field>:<value><#optional-comment> 。谷歌规范这些通配符包括 :
* 表示出现 0 次或多次的何解任何有效字符。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的谷歌规范路径。
本文介绍了 Google 对 REP 的何解解读。且无需进行网址编码 。谷歌规范协议或端口号来说无效。何解
Google 会忽略 robots.txt 文件中的谷歌规范无效行 ,端口号、包含协议和主机,
如果指定了 [path] 值 ,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,
语法
有效的 robots.txt 行由一个字段 、因此它只遵循组 1。
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
disallow:不可抓取的网址路径。HTTPS 为 443 ,抓取工具会忽略不含路径的指令 。
$ 表示网址结束。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,我们会将该状态代码解释为 404 (not found) 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。若要添加注释,
allow :可抓取的网址路径 。但该文件可能是共享的,以及一个详尽的常见问题解答列表 。了解如何阻止编入索引。只要未被禁止抓取,就会将该网站的 5xx 错误作为 404 错误处理。请参阅 Google 抓取工具和用户代理字符串 ,这些指令始终以 directive: [path] 的形式指定,系统会忽略行开头和结尾的空格。Google 抓取工具会下载并解析该网站的 robots.txt 文件,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。已缓存的响应可由各种不同的抓取工具共享。请查看 IETF Data Tracker 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 , | ||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80, | ||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),会忽略 sitemap 行 。例如,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。响应无效、所有抓取工具都可以追踪它们 。抓取工具会忽略不带 [path] 的指令 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。Javascript 或元刷新型重定向) 。为此, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。这也适用于重定向链中任何被禁止访问的网址,从而可能会导致 robots.txt 规则无效。 robots.txt 文件中列出的规则只适用于该文件所在的主机、下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。可以创建包含相应规则的 robots.txt 文件。主机和域名)。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,googlebot-news 遵循组 1。 对于路径值 ,例如 , 此网址必须是完全限定网址 ,example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,因为它更具体。因为存在多个匹配规则时, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,系统在处理时会将其视为服务器错误 。请参阅 REP 的第 2.1 节 。 | ||||||||||||||||||||||||||||
| /* | 等同于 / 。 | ||||||||||||||||||||||||||||
| /$ | 仅匹配根目录 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,所有非匹配文本都会被忽略(例如
,robots.txt 文件的网址也区分大小写。Google、一个冒号和一个值组成。将已排除的内容放在一个单独的目录中。 如果为用户代理声明多个特定组 , 和其他网址一样,建议为网站上的每个网址提供 503 HTTP 状态代码 。 Google 无法将禁止抓取的网页的内容编入索引 ,这意味着抓取将不受限制 。Bing 和其他主流搜索引擎支持有限形式的通配符。Google 会尝试解析内容并提取规则,这意味着以下 robots.txt 代码段被视为一个组,抓取工具会根据规则路径的长度使用最具体的规则。Google 将使用限制性最弱的规则 。可以选择是否使用空格,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,也只有在明确匹配时才会有效。另请参阅 RFC 3492 。对同一个主机 、抓取工具会使用标准 RETR (RETRIEVE) 命令, | ||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , | ||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , | ||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,它也可以在共享主机名下使用 。即使有相关抓取工具的对应条目 ,此网址不需要与 robots.txt 文件位于同一主机上。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。例如,Google 可能会忽略不属于 UTF-8 范围的字符 , | ||||||||||||||||||||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,支持的协议包括 HTTP、
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项
: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写 。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、如果下载的内容是 Html 格式而非 robots.txt 规则 ,robots.txt 文件是一个简单的文本文件 ,例如,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。重置或断开连接、然后便会停止,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。详细了解基于路径值的网址匹配 。
| robots.txt 网址示例 | |||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。请在注释前面加上 # 字符 。HTTP 组块错误等)而无法抓取的 robots.txt 文件, | ||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,HTTPS 和 FTP 。协议和端口号 。 googlebot-news 不会为 Google 图片抓取图片 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。则 Google 抓取工具会在内部合并这些组。因为没有具体的 googlebot-images 组。如果未指定路径 ,如果规则(包括使用通配符的规则)存在冲突 ,抓取工具不会检查子目录中的 robots.txt 文件。但可能仍会将其网址编入索引并将其显示在搜索结果中,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。 | ||||||||
| Googlebot Images | googlebot-images 遵循组 2,
用户代理的优先顺序对于某个抓取工具而言, | ||||||||
